Do not promote google, please

when searching for ahoxus, and unable to find it, i stumbled upon this gem.

if you want to use a 3rd party service, you should really use, at worse, duck.com :duck:

the syntax is basically the same!

https://duckduckgo.com/?q=achoz+site%3Ahttps%3A%2F%2Ftosdr.community%2F&t=h_&ia=web

and although there was only 1 result, while google brought up 2, including a direct link, at least it works anyway!


Opened FORUM-3 for this, I cannot reproduce this on our internal forum so it will take a while as its on the most bottom of our To-Do list

1 Like

fair enough

why can’t you reproduce, though?

“achoz” doesn’t work anymore, but coming up with a string that does is fairly trivial.

if i suggest the string here, however, it will stop working! :rofl:

I cannot reproduce it because whatever I type, the google part does not pop up.

For the google part to appear you have to type the enter key after searching for something that doesn’t exist. I tried “aaaaa” and could reproduce it. This seems to be a Discourse issue and happens in every Discourse forum. Perhaps there is a configuration or Discourse plugin to change it.

1 Like

I have updated the search component with a plugin to use our Metasearch engine :slight_smile: Let me know if this fixes the issue. I could reproduce it with @KnossosDomovoi steps.

2 Likes

Yeah, that fixed it for me. If for some reason it doesn’t work for someone, try reloading the page.

@JustinBack, could you please add a link to the Metasearch engine plugin? Administrators of other Discourse forums might find this topic here by searching for something similar and I think this plugin is quite useful.

awesome @JustinBack !

but i use other searx instances and the reason i pointed to duck with the emphasis on how it was good enough is because, sadly, searx often isn’t.

the challenge now is finding strings in which that will happen in this situation, without bringing it up here… so, let’s talk about this on telegram, shall we? :grin:

meanwhile, here are 2 related issue, with the ux:

the colour make the text impossible to read.

and “google” is still mentioned there. now completely misleading!

I have opened a Jira Ticket for this :slight_smile: FORUM-4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.