Hypothesis integration broken

When I started reviewing terms on edit.tosdr.org again, I noticed that their annotation system was replaced by something the devs called “Hypothesis”.

When I tried to annotate a point, this error showed up:

I tried this again using multiple browsers (Google Chrome and Mozilla Firefox), and using multiple platforms (Android and Microsoft Windows). And it still just as broken as the first try.

I cannot even make a point because of this error. It was working for the devs but not me. This is not just a matter of one user, but all users of Phoenix. THIS IS A VERY URGENT ISSUE BECAUSE IT PREVENTS US FROM CONTRIBUTING TO TERMS OF SERVICE; DIDN’T READ, AND UNTIL THE DEVS FIX THIS ERROR, NO MORE POINTS WILL BE MADE. THIS ISSUE NEEDS TO BE FIXED BEFORE IT IS TOO LATE.

(Sorry for using ALL CAPS, just emphasizing the very urgent issue)


This new annotation system has some bugs, main one being that Phoenix usernames containing spaces can’t annotate anymore.

Try removing spaces on your Phoenix username
MenuSettingsEdit User

I hope this will fix the issue,

Good reviewing!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.